SUMMARY
Receiving the following message in the QSYSOPR message queue:
Error: DataGate/400: License management error 5; please contact ASNA
DETAILS
The AS/400 open() C-Library/RECIO function failed to open the LMDB member of the LMDB file.
This open() is performed on a member that was just created in a previous program statement. Check the job log, if available.
CAUSE
There are two known reasons for this error, each with their own resolution.
Reason 1: The user profile DG8SVCPRF does not have *ALL authority to the LMDB file in DG8_40 or ASNA_DG8, depending on your version of Datagate/400.
Reason 2: For some reason, we are not able to add a new member or record because it already exists. This would be confirmed by the job log.
RESOLUTION
Reason1: Please confirm that the DG8SVCPRF user profile has *ALL authority to the DG8_40 (Classic) or ASNA_DG8 (.NET) library. This is more common on new installs of DataGate not installed under the QSECOFR account.
Reason 2: End DataGate for iSeries using the <InstallLib>/ENDDG8SVR command. Then remove the LMDB member from the LMDB file using the RMVM command.
RMVM FILE(xxx_xx/LMDB) MBR(LMDB)
Where xxx_xx = DG8_40 for DataGate Classic versions.
xxx_xx = ASNA_DG8 for Datagate for .NET versions.
Again, this would all be shown and confirmed in the job log.